Email service isn't accessible at the moment

Resolved
Major outage
Started almost 2 years ago Lasted 4 minutes

Affected

Email and SMS Service
Updates
  • Resolved
    Resolved

    Email service is now operational!

  • Investigating
    Investigating

    Email and SMS service isn't accessible at the moment